1. Welcome to the Painful Pleasures community! New members, please read the Rules of the Forum before posting. You should also introduce yourself here before submitting any other posts. If you're interested in sharing photos of your body mods, please read the Rules of the Gallery first. At any time, you can use the "Start a Conversation" feature to get private help from our moderators, Angel on the Edge, Dnd4evr, Rainbird, xXJarredXx, Revs, and Craftsman. Enjoy the forum!
    Dismiss Notice

Help!! Wet ear!!

Discussion in 'All Things Stretched' started by Cacieden, Apr 23, 2017.

  1. Cacieden

    Cacieden New Member

    Hi guys, I've had stretched ears at 1/2 inch for over 8 years! I decided I finally wanted to start stretching again. I had a great experience with using tape to go up to 9/16. I am attempting to heal with glass plugs and have constant wet ear. But even with my 8 year old, fully healed 1/2 inch ears, I could never wear glass, stone, or steel.. it always caused wet ear. (So I stuck with wood, always.) I'm trying desperately to heal this stretch but the wet ear is making it impossible. I tried just letting it go, and that didn't work. I tried washing them multiple times a day and letting them dry before putting the jewelry back in, that didn't work. It's bad to keep disturbing the healing piercing by removing the jewelry to wash it, but if I don't, I get crusty buildup like crazy!! I can't seem to win here. Someone please help, I'm losing hope :(
     
  2. dnd4evr

    dnd4evr Super Moderator Staff Member

    Welcome to the Painful Pleasures (PP) community! Please take a moment to tell us a bit more about yourself in the Introduce Yourself area. Also, please read the Rules of the Forum at your convenience.

    The gallery is available for viewing or posting. Without a login you will be able to see non-mature content, but you will not be able to post there or view mature content.

    If you have any questions about the forum or gallery, feel free to reach out to me or our other moderators, Angel on the Edge, Rainbird, Craftsman and xXJarredXx.

    To keep out unwanted spam messages, all new members must have their first 3 messages approved (vetted) by the moderators before they can post freely.

    The forum has undergone some recent changes. Many were for the good, but it also introduced a bug. When an unvetted member posts to an existing discussion, it does not show up as other posts do. If a fully vetted member posts, the section they post in is highlighted and the thread list has a green dot next to the thread they post in. Also if you click on "new posts" it will show up in the list. Unvetted members do not show at all. The only time an unvetted members post show is if they create a new thread and even then it's not very easy to find. PP is working on getting this fixed, but it may take some time.

    If you post to the forum for help and you don't get a reply you are not being ignored. Please send a private message and include a thread link.

    I don't think I'm the best guy for this, but I know who is. Hopefully we will have an answer for you shortly.
     

Share This Page